Rabu, 07 Desember 2011

Lab 5: MPLS VPN- PE CE EIGRP Routing





konfig PE1

hostname PE1
!
!
ip vrf BCA.KIRI
 rd 65000:2
 route-target export 65000:2
 route-target import 65000:2
!
ip vrf BRI.KIRI
 rd 65000:1
 route-target export 65000:1
 route-target import 65000:1
!
!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!        
interface FastEthernet0/0
 ip vrf forwarding BRI.KIRI
 ip address 192.168.0.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip vrf forwarding BCA.KIRI
 ip address 192.168.0.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.10.1 255.255.255.252
 speed 100
 full-duplex
 mpls ip
!
router eigrp 65000
 auto-summary
 !
 address-family ipv4 vrf BRI.KIRI
  redistribute bgp 65000 metric 1 1 1 1 1
  network 192.168.0.0
  auto-summary
  autonomous-system 100
 exit-address-family
!
router ospf 1
 log-adjacency-changes
 network 10.10.10.1 0.0.0.0 area 0
 network 192.168.10.1 0.0.0.0 area 0
!
router bgp 65000
 bgp log-neighbor-changes
 neighbor 10.10.10.2 remote-as 65000
 neighbor 10.10.10.2 update-source Loopback0
 !
 address-family ipv4
  no neighbor 10.10.10.2 activate
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.10.10.2 activate
  neighbor 10.10.10.2 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf BRI.KIRI
  redistribute connected
  redistribute static
  redistribute eigrp 100
  no synchronization
 exit-address-family
 !
 address-family ipv4 vrf BCA.KIRI
  no synchronization
 exit-address-family
!
ip forward-protocol nd
ip route vrf BRI.KIRI 10.0.0.1 255.255.255.255 192.168.0.2
!
!



konfig PE2


!
ip vrf BCA.KANAN
 rd 65000:2
 route-target export 65000:2
 route-target import 65000:2
!
ip vrf BRI.KANAN
 rd 65000:1
 route-target export 65000:1
 route-target import 65000:1
!
!
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!        
interface FastEthernet0/0
 ip vrf forwarding BCA.KANAN
 ip address 192.168.0.5 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip vrf forwarding BRI.KANAN
 ip address 192.168.1.5 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.20.2 255.255.255.252
 speed 100
 full-duplex
 mpls ip
!
router eigrp 65000
 auto-summary
 !
 address-family ipv4 vrf BRI.KANAN
  redistribute bgp 65000 metric 1 1 1 1 1
  network 192.168.0.0
  network 192.168.1.0
  auto-summary
  autonomous-system 100
 exit-address-family
!
router ospf 1
 log-adjacency-changes
 network 10.10.10.2 0.0.0.0 area 0
 network 192.168.20.2 0.0.0.0 area 0
!
router bgp 65000
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.10.1 remote-as 65000
 neighbor 10.10.10.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 10.10.10.1 activate
  neighbor 10.10.10.1 send-community extended
 exit-address-family
 !       
 address-family ipv4 vrf BRI.KANAN
  redistribute connected
  redistribute static
  redistribute eigrp 100
  no synchronization
 exit-address-family
 !
 address-family ipv4 vrf BCA.KANAN
  no synchronization
 exit-address-family
!
ip forward-protocol nd
ip route vrf BRI.KANAN 10.0.0.2 255.255.255.255 192.168.1.6
!
!
end



PE1#show mpls ldp nei
    Peer LDP Ident: 10.10.10.10:0; Local LDP Ident 10.10.10.1:0
    TCP connection: 10.10.10.10.26892 - 10.10.10.1.646
    State: Oper; Msgs sent/rcvd: 17/17; Downstream
    Up time: 00:08:24
    LDP discovery sources:
      FastEthernet1/0, Src IP addr: 192.168.10.2
        Addresses bound to peer LDP Ident:
          192.168.10.2    10.10.10.10     192.168.20.1   
PE1#

P#show mpls ldp nei
    Peer LDP Ident: 10.10.10.2:0; Local LDP Ident 10.10.10.10:0
    TCP connection: 10.10.10.2.646 - 10.10.10.10.11833
    State: Oper; Msgs sent/rcvd: 18/18; Downstream
    Up time: 00:09:13
    LDP discovery sources:
      FastEthernet0/1, Src IP addr: 192.168.20.2
        Addresses bound to peer LDP Ident:
          192.168.20.2    10.10.10.2     
    Peer LDP Ident: 10.10.10.1:0; Local LDP Ident 10.10.10.10:0
    TCP connection: 10.10.10.1.646 - 10.10.10.10.26892
    State: Oper; Msgs sent/rcvd: 18/18; Downstream
    Up time: 00:09:13
    LDP discovery sources:
      FastEthernet0/0, Src IP addr: 192.168.10.1
        Addresses bound to peer LDP Ident:
          192.168.10.1    10.10.10.1     
P#

PE2#show mpls ldp nei
    Peer LDP Ident: 10.10.10.10:0; Local LDP Ident 10.10.10.2:0
    TCP connection: 10.10.10.10.11833 - 10.10.10.2.646
    State: Oper; Msgs sent/rcvd: 19/19; Downstream
    Up time: 00:10:02
    LDP discovery sources:
      FastEthernet1/0, Src IP addr: 192.168.20.1
        Addresses bound to peer LDP Ident:
          192.168.10.2    10.10.10.10     192.168.20.1   
PE2#


CE- BRI-1
Gateway of last resort is 192.168.0.1 to network 0.0.0.0

     10.0.0.0/32 is subnetted, 2 subnets
D EX    10.0.0.2 [170/2560025856] via 192.168.0.1, 00:14:58, FastEthernet0/0
C       10.0.0.1 is directly connected, Loopback0
     192.168.0.0/30 is subnetted, 1 subnets
C       192.168.0.0 is directly connected, FastEthernet0/0
     192.168.1.0/30 is subnetted, 1 subnets
D EX    192.168.1.4
           [170/2560025856] via 192.168.0.1, 00:14:58, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.0.1
CE-BRI-1#

CE-BRI-2
     10.0.0.0/32 is subnetted, 2 subnets
C       10.0.0.2 is directly connected, Loopback0
D EX    10.0.0.1 [170/2560025856] via 192.168.1.5, 00:00:59, FastEthernet0/0
     192.168.0.0/30 is subnetted, 1 subnets
D       192.168.0.0 [90/307200] via 192.168.1.5, 00:00:59, FastEthernet0/0
     192.168.1.0/30 is subnetted, 1 subnets
C       192.168.1.4 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.1.5
CE-BRI-2#

CE-BRI-1#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
CE-BRI-1#ping 10.0.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/63/80 ms
CE-BRI-1#tracer 10.0.0.2

Type escape sequence to abort.
Tracing the route to 10.0.0.2

  1 192.168.0.1 4 msec 8 msec 24 msec
  2 192.168.10.2 [MPLS: Labels 16/19 Exp 0] 52 msec 44 msec 68 msec
  3 192.168.1.5 [MPLS: Label 19 Exp 0] 44 msec 28 msec 24 msec
  4 192.168.1.6 40 msec 36 msec *
CE-BRI-1#



CE-BRI-2#
CE-BRI-2#ping 10.0.0.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/53/100 ms
CE-BRI-2#tracer 10.0.0.1

Type escape sequence to abort.
Tracing the route to 10.0.0.1

  1 192.168.1.5 28 msec 12 msec 16 msec
  2 192.168.20.1 [MPLS: Labels 17/19 Exp 0] 40 msec 36 msec 68 msec
  3 192.168.0.1 [MPLS: Label 19 Exp 0] 40 msec 48 msec 52 msec
  4 192.168.0.2 48 msec 24 msec *
CE-BRI-2#

Tidak ada komentar:

Posting Komentar