Selasa, 06 Desember 2011

Hari ke - 4 Lab 10: BGP Attribute (community )

konfig R4

!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 24.24.24.4 255.255.255.0
 clock rate 2000000
!



router bgp 4
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.4 mask 255.255.255.255
 neighbor 24.24.24.2 remote-as 123
 no auto-summary
!


R4#sh ip bgp
BGP table version is 5, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 4.4.4.4/32       0.0.0.0                  0         32768 i
*> 11.11.11.11/32   24.24.24.2                             0 123 i
*> 22.22.22.22/32   24.24.24.2               0             0 123 i
*> 33.33.33.33/32   24.24.24.2                             0 123 i
R4#



konfig R1

router eigrp 1
 network 1.1.1.1 0.0.0.0
 network 12.12.12.1 0.0.0.0
 auto-summary
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 network 11.11.11.11 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 123
 no auto-summary
!
ip forward-protocol nd
!

!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0
 duplex auto
 speed auto
!


R1(config-router)#do sh ip bgp
BGP table version is 5, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i4.4.4.4/32       2.2.2.2                  0    100      0 4 i
*> 11.11.11.11/32   0.0.0.0                  0         32768 i
*>i22.22.22.22/32   2.2.2.2                  0    100      0 i
*>i33.33.33.33/32   3.3.3.3                  0    100      0 i
R1(config-router)#

Konfig R2

!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
 ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.2 255.255.255.0
 duplex auto
 speed auto


interface Serial0/0
 ip address 24.24.24.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto


!
router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 12.12.12.2 0.0.0.0
 network 23.23.23.2 0.0.0.0
 auto-summary
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 123
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 next-hop-self
 neighbor 3.3.3.3 remote-as 123
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 route-reflector-client
 neighbor 3.3.3.3 next-hop-self
 neighbor 24.24.24.4 remote-as 4
 no auto-summary
!


R2(config-router)#exit
R2(config)#do sh ip bgp
BGP table version is 5, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 4.4.4.4/32       24.24.24.4               0             0 4 i
*>i11.11.11.11/32   1.1.1.1                  0    100      0 i
*> 22.22.22.22/32   0.0.0.0                  0         32768 i
*>i33.33.33.33/32   3.3.3.3                  0    100      0 i
R2(config)#


konfig R3

interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
 ip address 33.33.33.33 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!


router eigrp 1
 network 3.3.3.3 0.0.0.0
 network 23.23.23.3 0.0.0.0
 auto-summary
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 123
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!

R3(config)#exit
R3#sh ip route
*Mar  1 00:19:57.383: %SYS-5-CONFIG_I: Configured from console by console
R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D    1.0.0.0/8 [90/435200] via 23.23.23.2, 00:10:14, FastEthernet0/0
D    2.0.0.0/8 [90/409600] via 23.23.23.2, 00:10:14, FastEthernet0/0
     33.0.0.0/32 is subnetted, 1 subnets
C       33.33.33.33 is directly connected, Loopback1
     3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       3.3.3.3/32 is directly connected, Loopback0
D       3.0.0.0/8 is a summary, 00:10:10, Null0
     4.0.0.0/32 is subnetted, 1 subnets
B       4.4.4.4 [200/0] via 2.2.2.2, 00:08:24
     23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       23.23.23.0/24 is directly connected, FastEthernet0/0
D       23.0.0.0/8 is a summary, 00:10:12, Null0
     22.0.0.0/32 is subnetted, 1 subnets
B       22.22.22.22 [200/0] via 2.2.2.2, 00:09:30
     11.0.0.0/32 is subnetted, 1 subnets
B       11.11.11.11 [200/0] via 1.1.1.1, 00:09:32
D    12.0.0.0/8 [90/307200] via 23.23.23.2, 00:10:18, FastEthernet0/0
R3#


R3#show ip bgp
BGP table version is 5, local router ID is 33.33.33.33
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i4.4.4.4/32       2.2.2.2                  0    100      0 4 i
*>i11.11.11.11/32   1.1.1.1                  0    100      0 i
*>i22.22.22.22/32   2.2.2.2                  0    100      0 i
*> 33.33.33.33/32   0.0.0.0                  0         32768 i
R3#


SET community menjadi NO EXPORT


!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 network 11.11.11.11 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 123
 neighbor 2.2.2.2 send-community
 neighbor 2.2.2.2 route-map NO-EXPORT out
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit 11.11.11.11
!
!
!
route-map NO-EXPORT permit 10
 match ip address 1
 set community no-export
!




R4#sh ip bgp
BGP table version is 6, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 4.4.4.4/32       0.0.0.0                  0         32768 i
*> 22.22.22.22/32   24.24.24.2               0             0 123 i
*> 33.33.33.33/32   24.24.24.2                             0 123 i
R4#


R2(config)#do sh ip bgp 11.11.11.11
BGP routing table entry for 11.11.11.11/32, version 6
Paths: (1 available, best #1, table Default-IP-Routing-Table, not advertised to EBGP peer)
  Advertised to update-groups:
        3
  Local
    1.1.1.1 (metric 409600) from 1.1.1.1 (11.11.11.11)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Community: no-export
R2(config)#

Set Community "no-advertise" di R3



router eigrp 1
 network 3.3.3.3 0.0.0.0
 network 23.23.23.3 0.0.0.0
 auto-summary
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 network 33.33.33.33 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 123
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 send-community
 neighbor 2.2.2.2 route-map NO-ADVERTISE out
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit 33.33.33.33


route-map NO-ADVERTISE permit 10
 match ip address 1
 set community no-advertise
!
!
!
!

R4
   Network          Next Hop            Metric LocPrf Weight Path
*> 4.4.4.4/32       0.0.0.0                  0         32768 i
*> 22.22.22.22/32   24.24.24.2               0             0 123 i
*> 33.33.33.33/32   24.24.24.2                             0 123 i
R4#

R1#sh ip bgp
BGP table version is 6, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i4.4.4.4/32       2.2.2.2                  0    100      0 4 i
*> 11.11.11.11/32   0.0.0.0                  0         32768 i
*>i22.22.22.22/32   2.2.2.2                  0    100      0 i
R1#

Set Community menjadi Local-AS

R2#show ip bgp
BGP table version is 5, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 4.4.4.4/32       24.24.24.4               0             0 4 i
*>i11.11.11.11/32   12.12.12.1               0    100      0 i
*> 22.22.22.22/32   0.0.0.0                  0         32768 i
*> 33.33.33.33/32   23.23.23.3               0    100      0 (3) i
R2#



KOnfigurasi R2

interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 12.12.12.2 0.0.0.0
 network 23.23.23.2 0.0.0.0
 auto-summary
!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 123
 bgp confederation peers 3
 network 22.22.22.22 mask 255.255.255.255
 neighbor 12.12.12.1 remote-as 12
 neighbor 12.12.12.1 next-hop-self
 neighbor 23.23.23.3 remote-as 3
 neighbor 23.23.23.3 next-hop-self
 neighbor 24.24.24.4 remote-as 4
 no auto-summary
!
ip forward-protocol nd
!

konfigurasi R1

!
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 123
 network 11.11.11.11 mask 255.255.255.255
 neighbor 12.12.12.2 remote-as 12
 neighbor 12.12.12.2 send-community
 neighbor 12.12.12.2 route-map LOCAL-AS out
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit 11.11.11.11
access-list 2 permit 11.11.11.11
!
!
!
route-map NO-EXPORT permit 10
 match ip address 1
 set community no-export
!
route-map LOCAL-AS permit 10
 match ip address 2
 set community local-AS




Konfigurasi R3

router eigrp 1
 network 3.3.3.3 0.0.0.0
 network 23.23.23.3 0.0.0.0
 auto-summary
!
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 123
 bgp confederation peers 12
 network 33.33.33.33 mask 255.255.255.255
 neighbor 23.23.23.2 remote-as 12
 no auto-summary
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 1 permit 33.33.33.33
!
!


R2#sh ip bgp 11.11.11.11
BGP routing table entry for 11.11.11.11/32, version 3
Paths: (1 available, best #1, table Default-IP-Routing-Table, not advertised outside local AS)
  Not advertised to any peer
  Local
    12.12.12.1 from 12.12.12.1 (11.11.11.11)
      Origin IGP, metric 0, localpref 100, valid, confed-internal, best
      Community: local-AS
R2#

Tidak ada komentar:

Posting Komentar