Selasa, 06 Desember 2011

Hari ke-4: Lab 12: BGP Aggregator

!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
 ip address 40.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 40.2.1.1 255.255.255.255
!
interface Loopback3
 ip address 40.3.1.1 255.255.255.255
!
interface Loopback4
 ip address 40.4.1.1 255.255.255.255
!
interface Loopback5
 ip address 40.5.1.1 255.255.255.255
!
interface Loopback6
 ip address 40.6.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 24.24.24.4 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.4 mask 255.255.255.255
 network 40.1.1.1 mask 255.255.255.255
 network 40.2.1.1 mask 255.255.255.255
 network 40.3.1.1 mask 255.255.255.255
 network 40.4.1.1 mask 255.255.255.255
 network 40.5.1.1 mask 255.255.255.255
 network 40.6.1.1 mask 255.255.255.255
 neighbor 24.24.24.2 remote-as 123
 no auto-summary
!
ip forward-protocol nd
!

R1(config)#do show ip bgp
BGP table version is 11, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i4.4.4.4/32       2.2.2.2                  0    100      0 4 i
*> 11.11.11.11/32   0.0.0.0                  0         32768 i
*>i22.22.22.22/32   2.2.2.2                  0    100      0 i
*>i33.33.33.33/32   3.3.3.3                  0    100      0 i
*>i40.1.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.2.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.3.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.4.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.5.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.6.1.1/32      2.2.2.2                  0    100      0 4 i
R1(config)#

R4(config)#router bgp 4
R4(config-router)#aggre
R4(config-router)#aggregate-address 40.0.0.0 255.248.0.0
R4(config-router)#


R1#show ip bgp
BGP table version is 12, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i4.4.4.4/32       2.2.2.2                  0    100      0 4 i
*> 11.11.11.11/32   0.0.0.0                  0         32768 i
*>i22.22.22.22/32   2.2.2.2                  0    100      0 i
*>i33.33.33.33/32   3.3.3.3                  0    100      0 i
*>i40.0.0.0/13      2.2.2.2                  0    100      0 4 i
*>i40.1.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.2.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.3.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.4.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.5.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.6.1.1/32      2.2.2.2                  0    100      0 4 i
R1#


R1#sh ip bgp 40.0.0.0
BGP routing table entry for 40.0.0.0/13, version 12
Paths: (1 available, best #1, table Default-IP-Routing-Table)
  Not advertised to any peer
  4, (aggregated by 4 4.4.4.4)
    2.2.2.2 (metric 409600) from 2.2.2.2 (22.22.22.22)
      Origin IGP, metric 0, localpref 100, valid, internal, atomic-aggregate, best
R1#



R4(config-router)#aggregate-address 40.0.0.0 255.248.0.0 summary-only
R4(config-router)#



R1#show ip bgp
BGP table version is 18, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i4.4.4.4/32       2.2.2.2                  0    100      0 4 i
*> 11.11.11.11/32   0.0.0.0                  0         32768 i
*>i22.22.22.22/32   2.2.2.2                  0    100      0 i
*>i33.33.33.33/32   3.3.3.3                  0    100      0 i
*>i40.0.0.0/13      2.2.2.2                  0    100      0 4 i
R1#


konfig aggregate supress

R4(config)#access-list 1 permit host 40.2.1.1
R4(config)#acc
R4(config)#access-list 1 permit host 40.3.1.1
R4(config)#acc
R4(config)#access-list 1 permit
R4(config)#access-list 1 permit host 40.4.1.1
R4(config)#acc
R4(config)#access-list 1 deny any
R4(config)#route-
R4(config)#route-map BLOK
R4(config-route-map)#mat
R4(config-route-map)#match ip addr
R4(config-route-map)#match ip address 1
R4(config-route-map)#router bgp 4
R4(config-router)#aggre
R4(config-router)#aggregate-address 40.0.0.0 255.248.0.0 sup
R4(config-router)#aggregate-address 40.0.0.0 255.248.0.0 suppress-map
R4(config-router)#aggregate-address 40.0.0.0 255.248.0.0 suppress-map BLOK
R4(config-router)#

R4#sh ip bgp

*Mar  1 00:39:44.739: %SYS-5-CONFIG_I: Configured from console by console
BGP table version is 27, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 4.4.4.4/32       0.0.0.0                  0         32768 i
*> 11.11.11.11/32   24.24.24.2                             0 123 i
*> 22.22.22.22/32   24.24.24.2               0             0 123 i
*> 33.33.33.33/32   24.24.24.2                             0 123 i
*> 40.0.0.0/13      0.0.0.0                            32768 i
*> 40.1.1.1/32      0.0.0.0                  0         32768 i
s> 40.2.1.1/32      0.0.0.0                  0         32768 i
s> 40.3.1.1/32      0.0.0.0                  0         32768 i
s> 40.4.1.1/32      0.0.0.0                  0         32768 i
*> 40.5.1.1/32      0.0.0.0                  0         32768 i
*> 40.6.1.1/32      0.0.0.0                  0         32768 i
R4#


R1#sh ip bgp
BGP table version is 21, local router ID is 11.11.11.11
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i4.4.4.4/32       2.2.2.2                  0    100      0 4 i
*> 11.11.11.11/32   0.0.0.0                  0         32768 i
*>i22.22.22.22/32   2.2.2.2                  0    100      0 i
*>i33.33.33.33/32   3.3.3.3                  0    100      0 i
*>i40.0.0.0/13      2.2.2.2                  0    100      0 4 i
*>i40.1.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.5.1.1/32      2.2.2.2                  0    100      0 4 i
*>i40.6.1.1/32      2.2.2.2                  0    100      0 4 i
R1#

Tidak ada komentar:

Posting Komentar