PENGERTIAN RIP
RIP adalah protokol routing dinamik yang berbasis distance vector. RIP menggunakan protokol UDP pada port 520 untuk mengirimkan informasi routing antar router. RIP menghitung routing terbaik berdasarkan perhitungan HOP. RIP membutuhkan waktu untuk melakukan converge. RIP membutuhkan power CPU yang rendah dan memory yang kecil daripada protokol yang lainnya.
KARAKTERISTIK RIP
- * Distance vector routing protocol
- * Hop count sebagi metric untuk memilih rute
- * Maximum hop count 15, hop ke 16 dianggap unreachable
- * Secara default routing update 30 detik sekali
- * RIPv1 (classfull routing protocol) tidak mengirimkan subnet mask pada update
- * RIPv2 (classless routing protocol) mengirimkan subnet mask pada update
Beberapa Gambaran Tentang RIP
1. Update
2. Summarization
3. Security
4. Split Horizon
5. Neighbor
6. Metric
7. Path Manipulation
8 Default Route
9. Timer
10. Update
berikut ini adalah soal lab yang saya kerjakan untuk Lab RIP
Lab 1: RIP Authentication
R1 Configuration
Router(config)#hostname R1
R1(config)#key chan
R1(config)#key cha
R1(config)#key chain RIP
R1(config-keychain)#key 1
R1(config-keychain-key)#key
R1(config-keychain-key)#key-string CISCO
R1(config-keychain-key)#exit
R1(config-keychain)#exit
R1(config)#inter
R1(config)#interface loopback0
R1(config-if)#ip adddr .
R1(config-if)#ip addr 1.1.1.1 255.255.255.255
R1(config-if)#no shut
R1(config-if)#inter fa0/0
R1(config-if)#ip addr 13.13.13.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#inter ser0
*Mar 1 00:02:35.487: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:02:36.487: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config)#inter s1/0
R1(config-if)#ip addr 12.12.12.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#ip rip aut
R1(config-if)#ip rip authentication mode
*Mar 1 00:03:00.151: %LINK-3-UPDOWN: Interface Serial1/0, changed state to upmd
*Mar 1 00:03:01.155: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up5
R1(config-if)#ip rip aut
R1(config-if)#ip rip authentication key
R1(config-if)#ip rip authentication key-chain RIP
R1(config-if)#exit
R1(config)#router rip
R1(config-router)#ver
R1(config-router)#version 2
R1(config-router)#network 0.0.0.0
R1(config-router)#no auto
R1(config-router)#no auto-summary
R1(config-router)#no auto-summary
R3 Configuration
Router(config)#hostname R3
R3(config)#key chain RIP
R3(config-keychain)#key 1
R3(config-keychain-key)#key
R3(config-keychain-key)#key-string CISCO
R3(config-keychain-key)#inter
R3(config-keychain-key)#exit
R3(config-keychain)#interface lo0
R3(config-if)#ip addr
*Mar 1 00:08:37.343: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up 2.2.2.2 255.255.255.255
R3(config-if)#exit
R3(config)#inter fa0/0
R3(config-if)#ip addr 23.23.23.2 255.255.255.0
R3(config-if)#ip rip aut
R3(config-if)#ip rip authentication mode text
R3(config-if)#ip rip auth
R3(config-if)#ip rip authentication key
R3(config-if)#ip rip authentication key-chain RIP
R3(config-if)#exit
R3(config)#interface serial 1/0
R3(config-if)#ip addr 12.12.12.2 255.255.255.0
R3(config-if)#ip rip aut
R3(config-if)#ip rip authentication md5
R3(config-if)#ip rip auth
R3(config-if)#ip rip authentication
R3(config-if)#ip rip authentication key-chain RIP
R3(config-if)#no shut
R3(config-if)#
*Mar 1 00:16:08.363: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
*Mar 1 00:16:09.367: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up
R3(config-if)#exit
R3(config)#inter
R3(config)#interface fa0/0
R3(config-if)#no shut
R3(config-if)#
*Mar 1 00:16:31.987: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:16:32.987: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed
konfigurasi R2
Router>ena
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#key chain RIP
R2(config-keychain)#key 1
R2(config-keychain-key)#key
R2(config-keychain-key)#key-string CISCO
R2(config-keychain-key)#interfa
R2(config-keychain-key)#exit
R2(config-keychain)#inter
R2(config)#inter
R2(config)#interface lo0
R2(config-if)#ip addr 3.3.3.3 255.255.255.255
R2(config-if)#exit
R2(config)#inter fa
R2(config)#inter fastEthernet 0/0
R2(config-if)#ip addr 13.13.13.3 255.255.255.0
R2(config-if)#no shut
R2(config-if)#inter face
*Mar 1 00:03:23.711: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
*Mar 1 00:03:24.711: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
^
R2(config)#inter face
R2(config)#interfa
R2(config)#interface fas
R2(config)#interface fastEthernet 0/1
R2(config-if)#ip addr 23.23.23.3 255.255.255.0
R2(config-if)#ip rip aut
R2(config-if)#ip rip authentication mode text
R2(config-if)#ip rip atu
R2(config-if)#ip rip auth
R2(config-if)#ip rip authentication key-cha
R2(config-if)#ip rip authentication key-chain RIP
R2(config-if)#exit
R2(config)#router rip
R2(config-router)#vers
R2(config-router)#version 2
R2(config-router)#network 0.0.0.0
R2(config-router)#no aut
R2(config-router)#no auto-summary
R2(config-router)#
LAB 2: RIP Split Horizon
konfigurasi FRSW
FRSW
Frame Relay Switching
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 201 interface Serial1/2 102
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 301 interface Serial1/2 103
!
interface Serial1/2
no ip address
encapsulation frame-relay
shutdown
serial restart-delay 0
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial1/0 201
frame-relay route 103 interface Serial1/1 301
!
konfigurasi R2
interface Serial1/0
ip address 123.123.123.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 123.123.123.3 201
frame-relay map ip 123.123.123.1 201 broadcast
!
konfigurasi R1
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.123 multipoint
frame-relay map ip 123.123.123.2 102 broadcast
frame-relay map ip 123.123.123.3 103 broadcast
!
R1(config)#
R1(config-if)# no ip split-horizon
R1(config-if)#do clear ip route*
Konfigurasi R3
!
interface Serial1/0
ip address 123.123.123.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 123.123.123.2 201
frame-relay map ip 123.123.123.1 201 broadcast
!
interface Serial1/1
nge check
Serial1/0 is up, line protocol is up
Internet address is 123.123.123.3/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is disabled
R1(config)#
R1(config-if)# no ip split-horizon
R1(config-if)#do clear ip route*
FRSW
Frame Relay Switching
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 201 interface Serial1/2 102
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 301 interface Serial1/2 103
!
interface Serial1/2
no ip address
encapsulation frame-relay
shutdown
serial restart-delay 0
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial1/0 201
frame-relay route 103 interface Serial1/1 301
!
konfigurasi R2
interface Serial1/0
ip address 123.123.123.2 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 123.123.123.3 201
frame-relay map ip 123.123.123.1 201 broadcast
!
konfigurasi R1
interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
!
interface Serial1/0.123 multipoint
frame-relay map ip 123.123.123.2 102 broadcast
frame-relay map ip 123.123.123.3 103 broadcast
!
R1(config)#
R1(config-if)# no ip split-horizon
R1(config-if)#do clear ip route*
Konfigurasi R3
!
interface Serial1/0
ip address 123.123.123.3 255.255.255.0
encapsulation frame-relay
serial restart-delay 0
frame-relay map ip 123.123.123.2 201
frame-relay map ip 123.123.123.1 201 broadcast
!
interface Serial1/1
nge check
Serial1/0 is up, line protocol is up
Internet address is 123.123.123.3/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.9
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is disabled
R1(config)#
R1(config-if)# no ip split-horizon
R1(config-if)#do clear ip route*
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback10
ip address 10.0.0.1 255.255.255.0
!
interface Loopback11
ip address 10.0.1.1 255.255.255.0
!
interface Loopback12
ip address 10.0.2.1 255.255.255.0
!
interface Loopback13
ip address 10.0.3.1 255.255.255.0
!
interface Loopback14
ip address 10.4.0.1 255.255.255.0
!
interface Loopback15
ip address 10.5.0.1 255.255.255.0
!
interface Loopback16
ip address 10.6.0.1 255.255.255.0
!
interface Loopback17
ip address 10.7.0.1 255.255.255.0
!
interface Loopback18
ip address 10.8.0.1 255.255.255.0
!
interface Loopback20
ip address 11.0.0.1 255.255.255.0
!
interface Loopback21
ip address 11.0.1.1 255.255.255.0
!
interface Loopback22
ip address 11.0.2.1 255.255.255.0
!
interface Loopback23
ip address 11.0.3.1 255.255.255.0
!
interface Loopback24
ip address 11.0.4.1 255.255.255.0
!
interface Loopback31
ip address 12.0.0.1 255.255.255.255
!
interface Loopback32
ip address 12.0.0.2 255.255.255.255
!
interface Loopback33
ip address 12.0.0.3 255.255.255.255
!
interface Loopback34
ip address 12.0.0.4 255.255.255.255
!
interface Serial1/0
ip address 12.12.12.1 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
network 1.0.0.0
network 10.0.0.0
network 11.0.0.0
network 12.0.0.0
no auto-summary
!
Lab 4: Convergence Timers
1(config)#router rip
R1(config-router)#timeR1(config-router)#timers basic ?
<0-4294967295> Interval between updates
R1(config-router)#timers basic 10 ?
<1-4294967295> Invalid
R1(config-router)#timers basic 10 ?
<1-4294967295> Invalid
R1(config-router)#timers basic 10 60 ?
<0-4294967295> Holddown
R1(config-router)#timers basic 10 60 60 ?
<1-4294967295> Flush
R1(config-router)#timers basic 10 60 60 80
R2(config-router)#timers basic 10 60 60 80
R2(config-router)#
R2(config)#int fa0/0
R2(config-if)#ip rip ad
R2(config-if)#ip rip advertise 30
R2(config-if)#
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 10 seconds, next due in 6 seconds
Invalid after 60 seconds, hold down 60, flushed after 80
Redistributing: rip
R1(config-router)# do sh ip prot
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 10 seconds, next due in 8 seconds
Invalid after 60 seconds, hold down 60, flushed after 80
Redistributing: rip
Lab 7: RIP-Filtering-AD
R1
Nodes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnetsNodes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 12.12.12.2, 00:00:04, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
R 3.3.3.3 [120/2] via 12.12.12.2, 00:00:04, Serial1/0
23.0.0.0/24 is subnetted, 1 subnets
R 23.23.23.0 [120/1] via 12.12.12.2, 00:00:04, Serial1/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Serial1/0
R1#
R1#sh ip route 3.3.3.3
Routing entry for 3.3.3.3/32
Known via "rip", distance 120, metric 2
Redistributing via rip
Last update from 12.12.12.2 on Serial1/0, 00:00:03 ago
Routing Descriptor Blocks:
* 12.12.12.2, from 12.12.12.2, 00:00:03 ago, via Serial1/0
Route metric is 2, traffic share count is 1
ype escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/13/24 ms
R1#
R1(config)#router rip
R1(config-router)#dis
R1(config-router)#dista
R1(config-router)#distance ?
<1-255> Administrative distance
R1(config-router)#distance 255 0.0.0.0 255.255.255.255 1
R1(config-router)#access
R1(config-router)#exit
R1(config)#acces
R1(config)#access-list 1 permit host 3.3.3.3
R1(config)#exit
R1#clear i
*Mar 1 00:14:46.355: %SYS-5-CONFIG_I: Configured from console by consolep route *
R1#sh ip route 3.3.3.3
% Network not in table
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#
lab 8: RIP- Filtering - Offset List
R1(config-router)#no distance 255 0.0.0.0 255.255.255.255 1
R1(config-router)#exit
R1(config)#no acc
R1(config)#no access-list 1
R1(config)#
2(config)#router rip
R2(config-router)#off
R2(config-router)#offset-list 1 out 16 s1/0
R2(config-router)#exit
R2(config)#acc
R2(config)#access-list 1 permit host 3.3.3.3
R1(config)#do sh ip rou 3.3.3.3
% Network not in table
R1(config)#exit
*Mar 1 00:17:41.807: RIP: sending v2 update to 224.0.0.9 via Serial1/0 (12.12.12.1)
*Mar 1 00:17:41.807: RIP: build update entries
*Mar 1 00:17:41.807: 1.1.1.1/32 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:17:41.807: 3.3.3.3/32 via 0.0.0.0, metric 16, tag 0
*Mar 1 00:17:55.775: RIP: sending v2 update to 224.0.0.9 via Loopback0 (1.1.1.1)
*Mar 1 00:17:55.775: RIP: build update entries
*Mar 1 00:17:55.775: 2.2.2.2/32 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:17:55.775: 3.3.3.3/32 via 0.0.0.0, metric 16, tag 0
*Mar 1 00:17:55.775: 12.12.12.0/24 via 0.0.0.0, metric 1, tag 0
*Mar 1 00:17:55.775: 23.23.23.0/24 via 0.0.0.0, metric 2, tag 0
*Mar 1 00:17:55.775: RIP: ignored v2 packet from 1.1.1.1 (sourced from one of our addresses)
*Mar 1 00:17:56.215: RIP: received v2 update from 12.12.12.2 on Serial1/0
*Mar 1 00:17:56.215: 2.2.2.2/32 via 0.0.0.0 in 1 hops
*Mar 1 00:17:56.215: 3.3.3.3/32 via 0.0.0.0 in 16 hops (inaccessible)
Lab 9: RIP-Unicast Update
IP packet debugging is on (detailed)
R1#
*Mar 1 00:20:13.215: IP: s=12.12.12.2 (Serial1/0), d=224.0.0.9, len 112, rcvd 2
*Mar 1 00:20:13.219: UDP src=520, dst=520
*Mar 1 00:20:29.595: IP: s=12.12.12.1 (local), d=224.0.0.9 (Serial1/0), len 72, sending broad/multicast
*Mar 1 00:20:29.599: UDP src=520, dst=520
*Mar 1 00:20:42.867: IP: s=12.12.12.2 (Serial1/0), d=224.0.0.9, len 112, rcvd 2
*Mar 1 00:20:42.867: UDP src=520, dst=520
R1(config)#router rip
R1(config-router)#pass
R1(config-router)#passive-interface s1/0
R1(config-router)#nei
R1(config-router)#neighbor 12.12.12.2
R1(config-router)#
R2(config)#router rip
R2(config-router)#pass
R2(config-router)#passive-interface s1/0
R2(config-router)#neig
R2(config-router)#neighbor 12.12.12.1
P packet debugging is on (detailed)
R1#
*Mar 1 00:23:51.939: IP: tableid=0, s=12.12
.12.2 (Serial1/0), d=12.12.12.1 (Serial1/0), routed via RIB
*Mar 1 00:23:51.939: IP: s=12.12.12.2 (Serial1/0), d=12.12.12.1 (Serial1/0), len 52, rcvd 3
*Mar 1 00:23:51.943: UDP src=520, dst=520
*Mar 1 00:24:17.523: IP: tableid=0, s=12.12.12.2 (Serial1/0), d=12.12.12.1 (Serial1/0), routed via RIB
*Mar 1 00:24:17.523: IP: s=12.12.12.2 (Serial1/0), d=12.12.12.1 (Serial1/0), len 52, rcvd 3
*Mar 1 00:24:17.527: UDP src=520, dst=520
lab 10
R2(config)#int fa0/0
R2(config-if)#ip rip v
R2(config-if)#ip rip v2-broadcast
R3(config)#int fa0/0
R3(config-if)#ip rip v
R3(config-if)#ip rip v2-broadcast
R3(config-if)#exit
R3(config)#do debug ip packet detail
IP packet debugging is on (detailed)
R3(config)#
*Mar 1 00:25:55.511: IP: s=23.23.23.2 (FastEthernet0/0), d=255.255.255.255, len 52, rcvd 2
*Mar 1 00:25:55.511: UDP src=520, dst=520
*Mar 1 00:26:22.271: IP: s=23.23.23.2 (FastEthernet0/0), d=255.255.255.255, len 52, rcvd 2
*Mar 1 00:26:22.271: UDP src=520, dst=520
Lab 11
R2#sh ip ro
*Mar 1 00:30:33.571: %SYS-5-CONFIG_I: Configured from console by consoleute
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 23.23.23.3 to network 0.0.0.0
1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 12.12.12.1, 00:00:07, Serial1/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
R 3.3.3.3 [120/1] via 23.23.23.3, 00:00:19, FastEthernet0/0
23.0.0.0/24 is subnetted, 1 subnets
C 23.23.23.0 is directly connected, FastEthernet0/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Serial1/0
R* 0.0.0.0/0 [120/1] via 23.23.23.3, 00:00:19, FastEthernet0/0
Lab 11: RIP Default Route - Default Information Originate
Serial1/2 unassigned YES unset administratively down down
Serial1/3 unassigned YES unset administratively down down
Loopback0 1.1.1.1 YES manual up up
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
R 2.2.2.2 [120/1] via 12.12.12.2, 00:00:02, Serial1/0
23.0.0.0/24 is subnetted, 1 subnets
R 23.23.23.0 [120/1] via 12.12.12.2, 00:00:02, Serial1/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Serial1/0
R1#sh start
startup-config is not present
R1#wr
Building configuration...
[OK]
Tidak ada komentar:
Posting Komentar